Greyscalegorilla.com

SEARCH FROM OVER 250 CINEMA 4D TUTORIALS

GSG HDRI Light Kit Pro Version 1.2 and Missing Textures fix. 99 Comments


Missing Texture Issue SOLVED!

Watch this video to see how to solve the “Missing Texture” issues you may have been getting. If you purchased version 1.0 of the Light Kit, make sure to check your email for the new version 1.2 and the Missing Texture Update. Ignore emails about version 1.1). All NEW purchases of the kit will, of course, include version 1.2 and the texture fix.

What’s New in Version 1.2

In this video, I wanted to show you what is new In version 1.2 of the HDRI Light Kit Pro.

New “Rainbow Studio” included in Version 1.2

Buy The HDRI Light Kit Now

City Kit
HDRI Studio Pack

Comment Rules

This is a friendly community. Please treat everyone with respect. We don't all have to agree, but we do have to be nice. Criticism is fine, but rude comments and name calling will be deleted. Use your real name and don't be spammy. Thanks for adding to the conversation.

99 Comments

  1. Good work, if there’s future light kits – like a 2.0 version, will people who’ve already bought the first one get a discount?

    Reply
    • I should of watched the entire video asking a question which is already answered!

      Reply
  2. Urgh, mine is still missing all the textures… Am I missing something? C4D R11

    Reply
    • Hi, Mats. There are still a few issues with R11. I am working to get these fixed as soon as possible. Sorry about the problems.

      Cheers,
      Nick

      Reply
  3. Nick, ever toughed of giving a kit away to the winner of the next 5sec project? That would be awesome.

    Reply
  4. KevinB

    Nick, When you’re working on a big project with lots of textures, how often should you do a Save Project? Is Save Project best used once everything is completed and ready for archiving? Thanks for all your help!

    Reply
    • Once you do it for the first time, you just have to make sure that if you add more textures to the scene, that you tell cinema that you want to bring that texture IN and NOT leave it where it is.

      Reply
  5. Mine are still missing textures as well. Online @ ejunkies it said you updated textures.

    Reply
  6. Andrew

    Still a few errors in R11 – If you make a folder in your project with the original textures and save project it will find that folder and bring them in.

    Had problems where if you saved your project it would not find the textures at all.

    Reply
  7. Harry Mitchell

    Thanks for the fix Nick. Will there be any similar content updates coming up for Photoshop for photographers?

    Reply
  8. Hi Nick, I was just wondering if having LIght Kit Pro users try this as a solution to their texture issues :

    In C4D, just go to “Preferences > Texture Paths” and set the Light Kit’s “tex” folder here as one of the 10 Paths you can set.

    Reply
  9. rich nosworthy

    Would be cool if you did a post showing links to your favourite renders people had done so far with your light kit. Nice bit of inspiration

    Reply
  10. Jamie

    Hey Gorilla, I’ve just started messing with c4d and i was wondering how you got more of those rendering boxes when you click render. i only have 2 you have like 9. If you or anyone on here can help me with that, that would be great.

    Reply
    • this is a guess but my thoughts are that it has to do with how many cores you have, one per core, my only basis for this answer is that I noticed the same thing with my computer, dual core, 2 buckets. contrastingly, a mac pro with 8 cores, 8 buckets.

      again this is a guess, I’d love to know the answer too

      Reply
    • Jamie

      ohhh yeah i guess that would make sense..i thought it was like a plugin or something that you can get that makes it go faster..i guess i just have to learn to be patient. :/

      Reply
      • Yep. thats it. There are no shortcuts when it comes to rendering. Chip speed, the number of chips, ram, and lower quality settings are the only thing that make renders faster.

        Reply
  11. I only received 1.1 update which has the same problems.
    The original email doesn’t work.

    Reply
  12. Hey Guys,

    I don’t know if this helps, but a workaround i did for 11 and the textures is: if you double click on the images inside the tex folder inside the grey scale content browser, and then do a save picture as, you can save the textures one by one. I made a folder inside the maxon/tex/ and called it grey scale tex. Once i saved all the images. I went into preferences in cinema, texture paths, and pointed to that folder as one of the paths. I restarted Cinema, and when i brought in the softboxes and everything else, they all seemed to stop giving me the missing texture errors.

    Raul

    Reply
  13. It seemed that whenever I saved a studio preset with a different name and tried to reopen it all the softbox texture files were then missing.

    Using 1.2 with 11.530.

    The ‘Fix’ is to make sure you do a ‘Save Project’ to start with. This copies the textures into a folder called ‘Tex’.

    This also corrects the GI Irradience Cache File path to your project folder, not Nicks which is there by default.

    Worked for me anyway! Hope that helps.

    Reply
  14. chetan

    WWOOWW!!! my jaaaaaw dropped looking at this pic.. :( wish i could buy it now!!

    Reply
  15. Steven Jenkins

    Just bought the light kit last night. I’m doing a few test renders now. Dang, I need a render farm, but this first render looks fantastic with the rainbow studio. Enjoying the tutorials, the files, the whole package. I’ve learned more about lighting in the past 2 hours than I had in the past 2 years. Thanks, Nick!

    Reply
  16. Sure Glad CS tools was for Free, I see you Love to use CS Tools, Now you model come soft boxes and add some backdrops, Use some xpresso to control the setups and want 70 bucks and you didn’t even complete it to work as a Plugin. Yes it makes scenes for Lazy C4d Users, However I expected you, one who has used for free tools Like CS tool to offer your Scenes for free too.

    I think your work is OK. Your tutorials are OK, You use the word UMMMM Way way to much, I have to stop listening and watch what you are doing, UMMMM. drives me crazy! Ummmm get it. Offer things for free then when you Learn how to Compile in Visual Studio maybe you can get some money for your Scenes. Ummmmm, I mean if one is using C4D they should Learn How to Light!, Ummmmm the Spotlight thingy is called a Beauty dish. You call it a Professional Studio and are clueless as to terms of Lighting. What no umbrellas, no gridspots, No Flags, Barn-doors, No GOBO’s. I guess CTO and ND FILTERS are out of the Question.

    Ummmm, HDRI Lighing KIT PRO. Do your Lighing will create HDRI Imgages, Professional ones to boot. Ummmm, So let me see, Your lighting setups will actual Create A completed High Dynamic Range Image just from using a Light setup. Now This is truly Professional. I cant Wait to see it in use at Pixar, Sony or Dreamworks. I have yet to see a HDRI movie except for a time lapse comp. Ummmm, I guess I am sold. Ummmm. I mean I must have it. Can I send you a PO being the Guru that you are. Ummm, I must have it

    Reply
    • chetan

      i have been watching his tutorials since a month, i just look at the content an not any other Ummmmmm’s.. thats helped me.

      Reply
    • Hey you’re right about the ummmm’s — (Nick, really you could actually work on that) — but then again Mike, can you link me to your website with all of YOUR free tutorials?

      Thanks! I would love to see it and learn from you.

      Reply
    • Why shouldn’t people be able to make money out of their work, Mike? Especially when so much of their other content is given away for free (tutorials).

      Do you work for free? I hope not.

      If it’s not professional enough for you, there’s no one saying you have to buy it. I’m assuming though, from your in-depth, badly written critique, that you already own and have used a copy of HDRI Lighting Kit – because you *really* seem to know what you’re talking about….

      I’m not sure there’s anything gracious about being personal about someone’s presenting style either. You score no points for those comments. Perhaps if you don’t like Nick’s “Ummmmms” then you shouldn’t watch his tutorials. We wouldn’t want you to be ‘driven crazy’ now, would we?

      Reply
    • I’m so so sorry you didn’t like the kit, Mike. Please contact me for a full refund.

      I do understand your points about adding more lights. I wanted to start with the basics and add more lights as they are built. I have many more lights and rigs planned for the Kit as new versions come out. Plus, new versions come at no cost to current owners of the kit.

      Thanks again for your review of the kit. Sorry about the UMMMS too. It’s something I’m working on. Trust me, I hate it as much as you do.

      Cheers,
      nick

      Reply
    • ALPHA DESIGN

      DAMN Nick! That’s what a professional do! You answered to him very very nice! Eventough you may know he is a mediocre troll that is so envious about you because his girlfriend has a picture of you in her laptop and is always talking about you! XD hahaha You are my hero! All your work deserves gratefullness! THANK YOU SO MUCH!!! :)

      Reply
  17. Chris

    I was making a flashlight and I had a visible light inside the bulb, looks great in it’s own scene. However, I groups the flashlight together, copied it over to one of your studios, and the light cannot be turned on. It just shows an “x”. When I try to change it to on, it auto defaults to “x”.

    Our bandwidth at work isn’t fantastic so I’m wondering if I may have missed a vital piece of info in one of your tuts?

    Reply
    • I think I may have your answer, did the scene you chose have a “light switch” object already in it at the bottom of your hierarchy? If it did, and it was turned on, the expresso in the background would disable that light by default and make it impossible to turn on.

      so, if there is a light switch in your scene at the bottom of your object manager, delete it or flip it and see if that solves the issue for you, it should because the object area-light is a real light source.

      Reply
    • Chris

      I thought about that, but wasn’t sure if that would affect the studio lighting. I am using GI.

      Reply
  18. if you want, I can take a look at the project file because without specifics about which ligths, which scene, what your settings are etc, its hard to give appropriate advice. yes, messing with the switch may change the lighting in the scene, but once the switch is disabled, all of the paramaters it was controlling and locking down can now be configured individually.

    shoot me an email with the project file as an attachment and ill take a look for you

    paulagostinelli@gmail.com
    or click my name to go to my website

    Reply
  19. Chris

    What about Anisotropy? Why is it not showing up? Works fine with default lighting and regular lights but not with texture lighting. If I flip the global switch it looks ridiculous.

    Reply
    • Chris

      Actually it would appear that anisotropic materials don’t work at all with GI…

      Reply
    • Anisotropy won’t work correctly with GI. What you can do is only use the spec of the light for the Anisotropy and turn off everything else.

      Reply
  20. Hey Nick,

    is there any chance you could send a new dl link for the latest upgrade? Your link expired that sucks!

    Reply
  21. IM TELLING VIETNAM TOM aka epic beard man ON YOU NICK!! lol

    Reply
  22. Taeron

    Hello,
    Is it possible to use a spot only for Shades Projector with “Hdri Light Kit Pro”?

    I do not find the function.

    Thank you

    Patrick

    Reply
  23. Hello Nick

    I am using C4D R11 and v1.2 of the lighting kit and I am missing a texture from the office room. It’s the office fluroescent HDR, from what I can make out.

    Is this an R11 problem?

    Reply
  24. Just noticed today that in Windows if you copy the new texture folder into basics and the permissions for that folder aren’t set correctly (default i think the group “Users” don’t have full perm).

    Once i fixed that it was back to working.

    Thanks for this kit its brilliant! :)

    Reply
  25. schultz

    Hey nick, i bought the HDIR light kit but i did not receive any message from you, can you resend it to me please?
    My email is phantom_lancer94@yahoo.com

    btw, the kit is awesome! <3 it! thanks a lot dude :)

    Reply
  26. Hi,

    We are doing some testing on our renderfarm, missing textures here, offcourse not installed on the rendefarm, but I did 1 test on a client server installed it but still no go and missing textures

    anyone some tips or how to!

    Urgent big project (longrendertimes) coming up.

    Thx

    Reply
    • Sorry to hear. Follow the instructions in the video for each of your render farms. The textures must be on every computer. Hope that helps.

      Reply
  27. Hey I’m on C4d 11.5 is it normal that the hdri sky object does not render properlly the reflections when i pick the dotted with spots hdr?
    (im following your cherry tut and the fact that the cherries are not pretty is rly bugging me)

    thanks

    Reply
  28. Anyone have problems doing a net render with version 1.2 of the HDRI Light Kit Pro. I getting this error.

    Missing Textures / Low Memory: Window 3.jpg (Softbox Texture)

    Any solutions?

    Reply
    • Hi, Raul,

      When using net render, make sure you install the Light Kit textures on all your net machines in the same place on the hard drive.

      Reply
    • Nick, I installed the full version of C4D and placed the Light Kit lib and texture where they need to go i also placed the lib in the lib folder in the net render. The problem is net render doesn’t have a tex folder so i think that’s the problem.

      Nick would you be interested in making a video tutorial for using your Light Kit Pro with Net Render. I think it would be helpful for the community.

      Reply
      • Cairo

        I’m a bit tired right now but I was just about to start using Net Render with GSG HDRI Light Kit Pro in a sharp project for the first time. First I got this problem with the textures missing, so okey, I found that map with the GSGTextures and put it in C:/Program Files/MAXON/NET Render R 12 Client/tex/GSGTextures/ – so far so good, but then I also get this error on all clients that Window3.jpg is missing. But I double-checked and it’s there along with the other textures O.o

        Reply
    • TheDude

      Has nothing to do with the light kit.

      You need to do some research on rendering with net render first, textures need to go into the data path specified under net server network settings.

      Reply
  29. The Dude.

    How about you watch your tone first off. I have done my research which is limited since all I can find is this tutorial on c4dtraining.com on setting up a net render.

    http://www.c4dtraining.com/Tutorials/netRender/netRender.html

    I have placed the GSGTextures folder in the Project folder that is created in the Project Save. I have placed the GSG Light Kit Pro.lib plus GSGTextures in the full C4D 11.5 folders of both computers. I am still getting a missing textures for the jpg of the lights so since its the Light Kit Pro jpg’s that’s missing Im asking Nick for his help.

    Nick balls in your court for feedback.

    Reply
    • Hi Raul,

      The only think that I can think is that the textures are in a slightly different path than on the machine that it was saved on. In other words, the textures have to be EXACTLY in the same spot on every machine, or It won’t be seen. NET renders can be tricky, but with enough patience and a well setup farm, it can really go fast. Let me know what comes of this. Thanks for getting the kit!

      Reply
    • TheDude

      Tone does not transfer over the internet, take my answer for what it is – I answered your problem 100%. Again, you should have researched and tested other projects that use external textures to see where the problem lies. Sending Nick a private email in the first place avoids making his product look bad by claiming it doesnt work with net render. If Nick did not have an answer, then would be the time to post on a public forum.

      Reply
    • Raul V

      The Dude,

      Like you stated tone does not transfer over the internet and Nick didn’t have a working solution unless I misunderstood his solution. GSG Light Kit Pro is a great product and I recommend it to every C4D user. That its not clear how to implement with Net Render off the bat is something that needs to be documented by Nick for future user.

      Reply
  30. Nick I figured it out after Grundly on Mograph.net brought up the Data Path. I took a shot in the dark and moved your the Tex folder with the GSG textures into the: “user/administrator/name_of_project_folder/” After I added the job to the Net Render. That got Net Render to work but now all my rendered stills look weird. I think that’s more to do with the Realflow plugin mech.

    Reply
    • Thank you soo much for this post! Was in a mad rush to figure out what the issue was until I found this.
      Amazing plugin/preset Nick! Also save my life on this project by cutting my light tweaking to none. Can I recommend putting a quick net render tutorial on your next version of the HDRI.

      Reply
  31. Jakob

    Hi Nick,
    really nice tool. I like to use it for every work. But I have a little problem now. Is it possible to catch the shadows of a scene? It works with Multipass when I switch off the Global Light. But is there any way with GI Light and Shadows?

    Thanks so much,
    good job.

    Jakob

    Reply
    • Unfortunately, there is no easy way to “Shadow Catch” with GI. GI doesn’t produce shadows really. It just lights the scene, so there is no way to get that information. There are workarounds with mattes and passes, but I’m no expert on it. I am working on an easy way to do this. You will bet I will post a tut if I make sense of it.

      Reply
  32. Billy Chaw

    Hi Gorilla,

    After I followed your video tutorials and make so sure that install the “HDRI Light Kit Pro” correctlly, but this dialog box will showing up which note “Texture Error” when I was trying to do a render in this studio “WindowLightStudio.c4d”. Please tell me how to fix it? My Cinema 4D version is R11.027 on Mac.

    Thanks!

    Reply
    • Sorry about the problem, Billy. So you installed the textures in the “tex” folder and it’s still not finding it?

      Reply
    • Billy Chaw

      I remember that your video tutorial didn’t mention any issue about “TO INSTALL THE TEXTURES”, it just teach me dragging the “greyscalegorillalightkitpro.lib4d” into the “browser” folder of C4D, then just open any parts of HDRI Light Kit Pro from the Content Browser of C4D. So.. if there is any additional issues about install, please tell me this way.

      Thanks!

      Reply
    • Billy Chaw

      Sorry.. where is the video? I can’t find it..

      Reply
    • Billy Chaw

      Sorry I posted with mistake.. just del this post pls..

      Reply
  33. Luke Wheldon

    Ahhhhhhhhhhhh. Lovely.

    That’s taken a lot of stress away.

    Thank you!

    Reply
  34. hiiii when i render in cinema 4d r12 it says that c4d cant write the irradiance cache file or some crap like that can anyone help me ive asked everywhre and im going maaad!!! :(

    Reply
  35. Hey I’m a little late on this because I just got it can someone post a download link or re-email the textures to me?

    Reply
  36. This is very interesting, You are a very skilled blogger. I have joined your feed and look forward to seeking more of your wonderful post. Also, I have shared your site in my social networks!

    Reply
  37. Hey Nick,
    I just got City Kit 1.2 and I’m getting the missing texture popups, can you email the textures folder please? thanks.

    Reply
    • Hi Nic,
      Sorry about the problems. If you are getting Sky Errors, then you can ignore them. Drop us a line under the support tab at the top if you have any more questions. We will make sure you are all set.

      Thanks,
      Nick

      Reply
  38. If the above doesn’t work fix this for you there’s one last detail you should check. In your netRender folder, there’s your c4d project folder (with the tex containing all your nice little textures from a Save Project you probably ran) and there’s the user folder.

    The second you upload the .c4d project to the NetRender server it duplicates the .c4d project into child folders [ user->administrator->”c4d project”->c4d_project.c4d

    Here’s the thing, it doesn’t take your “tex” folder with it when it duplicates. You need to make sure that is also uploaded or you duplicate the “tex” folder since it is being referenced natively.

    Reply

Leave a Reply

Comment Rules

This is a friendly community. Please treat everyone with respect. We don't all have to agree, but we do have to be nice. Criticism is fine, but rude comments and name calling will be deleted. Use your real name and don't be spammy. Thanks for adding to the conversation.